Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 18:00 CEST
Scheduled
We would like to inform you that the National electronic balloting application (EB3) will be temporarily unavailable due to essential technical maintenance. The downtime is scheduled for Thursday, 23 October, starting at 18:00 CEST (Central European Summer Time), and is expected to last approximately three hours.
During this period, access to the balloting application will be interrupted. Once the system is back online, you will be able to resume voting as usual.
Thank you for your understanding and cooperation.
Posted Oct 19, 2025 - 10:42 CEST
This scheduled maintenance affected: Standards Development (National Ballots).